Delays in Order Processing

Incident Report for Janis Commerce

Resolved

This incident has been resolved.

We identified that an integration anomaly combined with a high volume of traffic from a specific account was causing a generalized delay in the VTEX platform's order process.

A robust update to our resource allocation logic has been deployed. This permanent solution isolates individual integration issues, ensuring that localized spikes or errors no longer impact the overall performance of our infrastructure.
Posted Dec 29, 2025 - 23:07 GMT-03:00

Monitoring

After identifying the root cause, we have implemented a permanent solution to prevent this issue from recurring in the future. We are monitoring the results.
Posted Dec 29, 2025 - 22:21 GMT-03:00

Identified

We have identified the root cause of the issue and are currently working on mitigation efforts
Posted Dec 29, 2025 - 21:58 GMT-03:00

Update

We are continuing to investigate this issue.
Posted Dec 29, 2025 - 21:35 GMT-03:00

Investigating

We are investigating delays specifically affecting our order processing services
Posted Dec 29, 2025 - 21:33 GMT-03:00
This incident affected: JanisV2 (Api, Backoffice).