Elevated Errors

Incident Report for Janis Commerce

Postmortem

About the interruption of our main service that we experienced on October 20 between 04:10 hs and 20:00 hs (UTC-3).

We fully understand that this outage significantly affected your operations and your ability to process orders. We take this impact very seriously and are using this experience to further strengthen our infrastructure resilience and refine our recovery procedures, ensuring that each event translates into tangible improvements in reliability and response.

Incident summary

The root cause of this prolonged interruption originated from an external failure affecting our operations - a large-scale outage in the infrastructure of our cloud service provider, Amazon Web Services (AWS).

This incident impacted critical components that support our order processing platform and other essential functionalities, resulting in a service disruption across both Janis Legacy and Janis V2 environments..

Our response and service recovery

Our engineering and infrastructure team acted immediately and remained on high alert throughout the event.

  • We continuously monitored our infrastructure and the evolving situation at AWS, ensuring full visibility and rapid response to every change.
  • Our teams worked relentlessly on mitigation strategies and contingency actions to minimize downtime and restore operations as soon as external conditions allowed.
  • Full service recovery was achieved at 20:00 hs (UTC-3), confirming that order processing and all platform functionalities had returned to normal.

Our top priority throughout was restoring your operations as fast as possible.

We’d like to hear from you

We value your feedback. If you have comments on our response or communications during this incident, please reach out to our Customer Success team.

Contact Customer Success

Posted Oct 21, 2025 - 13:55 GMT-03:00

Resolved

AWS Incident Resolved

AWS experienced a major operational disruption in the us-east-1 region that severely impacted multiple core services — including EC2, Lambda, and DynamoDB — throughout the day.

As a result, between 04:11 and 20:00 on October 20, 2025 (UTC-3 – Argentina), Janis Legacy was unavailable for most of the period, while Janis V2 faced a prolonged full outage followed by partial degradation before full recovery.

AWS has confirmed that the incident has been fully resolved, and all Janis systems are now operating normally. We continue to monitor performance closely to ensure ongoing stability and are conducting a full impact assessment to identify any operational consequences and define corrective actions where necessary.

We will share additional updates only if new information becomes available.
Posted Oct 20, 2025 - 23:23 GMT-03:00

Monitoring

We’re seeing a strong recovery across Janis services. Both V2 and Legacy are now operational, though we’ll keep monitoring for any residual errors or performance issues.

The AWS incident is still open, but recovery continues. We’ll post another update within the following hours or sooner if anything changes.
Posted Oct 20, 2025 - 19:46 GMT-03:00

Update

We’re still seeing intermittent errors affecting parts of our platform, including our Backoffice and API operations. Our team is focused on reducing impact on critical processes. AWS has identified the root cause and continues working on mitigation. We’ll provide another update within the next hour or sooner if new information becomes available.
Posted Oct 20, 2025 - 15:48 GMT-03:00

Update

The AWS incident is still ongoing. Our Legacy platform remains down, and V2 is experiencing a partial outage, with increased errors and degraded performance.
We’re tracking the situation closely and coordinating with AWS as they continue mitigation efforts. No ETA yet, but we’ll share another update within the hour or sooner if conditions change.
Posted Oct 20, 2025 - 14:14 GMT-03:00

Update

We’re aware of how this issue is impacting your operations and want to assure you it has our full attention. Our cloud provider is actively working to restore normal service as quickly as possible. While we don’t have a firm ETA yet, we’re fully focused on reaching a complete resolution. We appreciate your patience and will keep you informed with updates every hour or sooner if needed.
Posted Oct 20, 2025 - 12:52 GMT-03:00

Update

Our cloud provider is actively working to resolve the issue. We’re seeing signs of recovery — our V2 platform is back online and we’re checking for any remaining errors or degraded performance. Legacy is still affected. Thanks for your patience — we’ll share another update within the hour or sooner if needed.
Posted Oct 20, 2025 - 09:00 GMT-03:00

Identified

Our public cloud provider has identified the root cause of the issue. We are beginning to see signs of recovery, and mitigation efforts are in progress.
Posted Oct 20, 2025 - 07:58 GMT-03:00

Investigating

We are investigating extended delays to use some resources of our platform.
Posted Oct 20, 2025 - 05:00 GMT-03:00
This incident affected: Janis v1 (Legacy) (Janis API v1, Janis BackOffice v1) and JanisV2 (Api, Backoffice).